Do you have a Garmin or a Suunto and you will go for a surf soon, than it would be great if you can sign-up for the Beta sync function to automatically sync your windsurf sessions from Garmin Connect and Suunto with this website. 

You can register via: MY DASBOARD -> MY ITEMS -> MY DEVICES

Please let's us know it it works as expected in this fourm message. 

Hello, i've signed up for the sync function for Suunto, it would be so nice if it works.

I will let you know !


I did 2 little sessions today, I've synchronized my GPS on the suunto app, but I can't see my sessions on GPSSpeedsurfing ?
I know the sync worked because I have also done it with strava, and I can see my sessions there.

note: on the suunto app, Strava & Gps-speedsurfing are both displayed "connected".

I signed up for Garmin connect.

21-03-2021 first session automatic upload, small difference with the GT31.

Succesfully signed-up and connected with the Suunto App.

Seems to sync. No sessions are visible in the GP3S website though. Do you need to have a paid subscription for this to work?

Would be a really really great feature! Fingers crossed to get it up and running.

Regards, Eric.

Hi, the auto-sync will be a free service , so let's try it , please report bugs to the forum or 

I recently created an account and uploaded some sessions manually, but now I'm connected with Suunto App.

Will my history also be imported automatically or is there another way to import my history?

Once your account is setup to sync activities with Suunto, Garmin or Coros, all new activities that meet the windsurfing criteria will be synced. 

Historic sessions will not be synced. 

Hello, any idea why the sync is not working with the suunto app ?

Activity is set to windsurfing, so the problem is not here.

Hi Sebas,

Thnx for the feedback, would be nice to have bug reports as detailed as possible, in this case please forward session date & account info to our email box at , we have had some succesfull sync's with Suunto, but not all of them, so need more info to solve this, please keep in mind it's beta :) 

Did a couple tests with the Suunto earlier this week. Until the day before yesterday no results, Yesterday did a short (windsurf) walk and that came up on the site. So today I used the Suunto (Ambit 3 Peak) and the Garmin (Garmin Fenix 6 Pro) during the session and the results from the Suunto appeared on the site.

I renamed the activity surfen on the Garmin to Windsurfen and connected the device under MY DEVICES, Unfortunaty no results from the Garmin after the session. 

I also tried the connection with suunto. It's listed like strava as a connected service in the suunto app. Today the session pops up as session I can post on the tab ''post session'. Unfortunately almost everything is 0. Luckily I can use the sml file to post manually. Very nice that you are working on this connections wirh suunto, coros and garmin. Hopefully it will work in the future for suunto as well. Thank you!

Today I got the same as Peter with the Suunto, run values stay at 0 (autouploadid=454090)

I tried the auto upload with my suunto and too bad but the auto upload decreases the session. I did one on the Foil last friday. There is a difference of 2 km/h with the locosys GT and also 2 km/h with a normal upload with the suunto.

Today i did a slalom speed session and the difference was 6 km/h with the locosys and the normal Suunto upload. It seems the auto upload dos not transfers al the data to the gp3s site 

Thanks everyone for BETA testing. We have just released the first release with Garmin, Coros and Suunto sync.



PLEASE reconnect your device if you are a GARMIN or SUUNTO user to continue using the sync.  

For Beta testers only: PLEASE also delete your registration to the Test GP3S app on the Garmin or Suunto websitte. 

It is not possible to cancel the registration on the suunto app... There is no button or option to do so.

@ Sebastien; If you click on the setting and then connected apps you can then click on the gp3s test app. And there you can disconnect the app. This way it will be deleted.

Thank you for your help Rob, but the steps you described were the one I was doing. When I click on the gp3s app, I can't disconnect, I just have the text "connected" displayed.
I've successfully tried the same process with the strava app, so I really don't know what is the problem here.


To test the feature I've created another suunto account and another gp3s account, but now I'm struggling with the connection between the 2 app.
When I enter the suunto account name and password here :
I get this error message :

OAuth Error

error="invalid_client", error_description="Bad client credentials"

Same here connecting Suunto.

Had some trouble connecting with the account on Suunto App, changed password. After this I succesfully logged in to suunto app using the link below.

after succesfully logging  in:

OAuth Error

error="invalid_client", error_description="Bad client credentials"

Thnx for reporting and testing, we will get on to this ....

Login has disappeared on de suunto website. 

MySuunto service is now shut down and replaced by our new Suunto product registration service. All your products registered earlier to MySuunto, continue to be eligible for our international warranty under the warranty terms.

anything to do with this. The app is working

Same here: When I click on the gp3s app, I can't disconnect, I just have the text "connected" displayed. Re-installing the app did not help.

The automatic sync was up and running but has stopped working without any changes from my side.

So i am stuck for now. Any suggestions are highly appreciated!

something changes for suunto connection of accounts with suunto :


now a webserver 500 error:'s not you it's us. oh no an Error 500

something changes for suunto connection of accounts with suunto :


now a webserver 500 error:'s not you it's us. oh no an Error 500

I tried yesterday to upload a session by mine Suunto 5 and it didn't worked, I had the same messege when I registrated my suunto acount in your site.'s not you it's us. oh no an Error 500


We're experiencing an internal server problem.


Thnx for the feedback, it appears Suunto has pushed some changes for his platform, so the initial setup is not working anymore, we will contact Suunto to see what's going on.... we did not do any changes at our side, so a bit frustrating for us as well.....

Tested with Suunto and working authentication and connection. Will need to check after my first session if I can see my session

I've connected also gamrin connect.


How did it work with the garmin conect app I was surfing yesterday with my garmin watch. where can i upload my session? Can somebody help me?

Best Regards